Kawasaki Forum :: KawasakiWorld.com - Reply to Topic
Thread: Does anyone know about a gear shift sensor on a 01 zx12 Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Kawasaki Forum :: KawasakiWorld.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
05-20-2019 03:06 AM
SteveW Its under the front sprocker cover.
You can first try replacing the contact spring and pin under it.
Worked for me for a few years, then it stopped again and I installed a brand new switch last year
05-20-2019 12:48 AM
ninjayorkie some of the picture links aren't opening up (but you can still download them) you will have to use a magnifying glass for some of them till I can figure out why or repost the pictures if I still have them.
05-20-2019 12:35 AM
ninjayorkie This is what I did for the zx-9r.net site, so remember this is for the zx-9r, and on the zx12B3 onwards there is a diode in the system that does away with one of the switch wire lines.

Clutch switch checking, cleaning and/or replacing, with pictures. 8) Pt No 27010-1094

Make sure bike is out of gear before you start.

This will help sort out, Bike won't start with the clutch in, Engine only starts in neutral with the clutch out, the bike only starts with the clutch held in, and other variations, and some intermittent neutral lights.

If the engine does not turn over with the shorting link fitted as shown it the pictures, then it's not the clutch switch, but clean it anyway.

Tools 5mm Allen driver or key
Large instrument screwdriver or small screwdriver
Scotch Brite or similar, see the last picture.






















Coat the contacts in Vaseline after cleaning to help stop future corrosion.



Now put the bike back together.
05-19-2019 11:27 PM
simlog I've got the same problem. When it's cold the neutral light doesn't work or at best is intermittent. So where/which sensor(s)/switches(s) should I take a look at. I ride a ZX12 but I don't do much on it mechanically so please assume absolute noob when giving instructions
09-25-2016 01:22 PM
Redrider2k2 My neutral light was intermittent for a while also. It was mostly just annoying. It wouldn't come on at initial start up so it would force you to pick it up off the side stand and then, once running, it would light up again and you could set it back on it's stand. I thought about fixing it but then it pitched the #3 connecting rod through the case...Suddenly wasn't so important anymore
09-21-2016 03:52 PM
SteveW Have a read of the zx9 forum link Yorkie posted
09-21-2016 03:44 PM
BigSkip765 Okay were would the clutch switch be underneath the tank and i got someone who has spare sensors from a running 12
09-21-2016 03:28 PM
SteveW
Quote:
Originally Posted by BigSkip765 View Post
What are some steps i can take to make sure it come back on. I ask that because with the clutch engaged the bike doesn't want to start unless its in neutral
Quote:
Originally Posted by ninjayorkie View Post
You probably want to be doing some clutch switch checking, this is for a zx9 but its the same system. zx-9r.net :: View topic - Clutch switch checking, cleaning and/or replacing.

Part number for a new one 27010-1094 $22 it's used on loads of kawasaki bikes.
Yeah, I'd look into Yorkie's info about the clutch switch also having an issue
09-21-2016 01:02 PM
MetalMagician My A model does this intermittently too. Sometimes it will start and won't be able to idle while on side stand because it thinks it's in gear. Other than that it all works as should you just have to remember if you're in neutral. It really doesn't bother me enough to want to replace it.
09-21-2016 08:58 AM
ninjayorkie You probably want to be doing some clutch switch checking, this is for a zx9 but its the same system. zx-9r.net :: View topic - Clutch switch checking, cleaning and/or replacing.

Part number for a new one 27010-1094 $22 it's used on loads of kawasaki bikes.
09-21-2016 07:37 AM
BigSkip765 What are some steps i can take to make sure it come back on. I ask that because with the clutch engaged the bike doesn't want to start unless its in neutral
09-21-2016 04:40 AM
SteveW Yeah, but hasnt bothered me that much.. New cost too much, cant really find one with low KM either
09-20-2016 05:55 PM
BigSkip765 So have you thought of replacing it
09-20-2016 04:32 PM
SteveW Mine does it all the time, I've just learnt to live with it. I've even put in a new spring and contactor behind the sensor and it still does it when it warms up..
09-20-2016 09:15 AM
BigSkip765
Does anyone know about a gear shift sensor on a 01 zx12

I got a 01 zx12 just last night i was right the neutral indcator stop showing on the dash. So i was told uplug the connectors on the kick stand and it came back on but i dont want to keeping doing that. The shop said its a gear shift sensor can some send pics of it ir just help in the process thanks all

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome