Kawasaki Forum :: KawasakiWorld.com - Reply to Topic
Thread: Dont know if my clutch is slipping Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Kawasaki Forum :: KawasakiWorld.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
10-18-2018 03:45 PM
KZScott if the cable is too tight then it can slip. adjust the free play.
10-18-2018 07:01 AM
Hibs Sounds like probably the clutch mate. Only one way to find out, pull it apart and inspect your fibers/plates.
10-17-2018 01:09 AM
Abel Visagie
Dont know if my clutch is slipping

Hi Guys

Ok so im new and i am dumb at this shit but it is conserning me abit
i have a 2011 ZX10R with abt 11000km on the clock

this weekend i went riding and around 8 to 9000Rpm when i bang it it felt like my clutch was slipping in 4th and 5th gear now my Rpm jumped so this automaticaly tells me clutch is a gonner or so i think

my lever has almost no free play can this be the problem? or do you think it is friqtion plates that is a gonner i have done maby 2 burnouts with the bike in total and use my quick shifter almost always so can it be that the burnouts caused this but i have to say befour the slipping the burnout took place well around 9000km on the clocks so 2000km without no problem?

i dont drag the clutch hevy on pull off so i dont know

maby it is just time for a new one what do you think?

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome