Kawasaki Forum :: KawasakiWorld.com - Search Results
Advanced Search
Showing results 1 to 5 of 5
Search took 0.00 seconds.
Search: Posts Made By: Habes 1206
Forum: ZX-12R   03-14-2018, 06:57 PM
Replies: 15
Views: 3,692
Posted By Habes 1206
Well fixed the exhaust cam position and still...

Well fixed the exhaust cam position and still wouldn't start.

Then found this - joy of working with stuff from the wreckers :)

Running now so all good!
Forum: ZX-12R   02-27-2018, 06:10 PM
Replies: 15
Views: 3,692
Posted By Habes 1206
Looks like one tooth out on the exhaust cam. ...

Looks like one tooth out on the exhaust cam.

Thanks everyone for the suggestions.
Forum: ZX-12R   02-23-2018, 08:06 PM
Replies: 15
Views: 3,692
Posted By Habes 1206
Duck00 - atmospheric pressure sensor - will that...

Duck00 - atmospheric pressure sensor - will that show as error code on FI light?

Dastardly - all hoses look ok and connected

rmk - everything seems to be plugged in correctly but will double...
Forum: ZX-12R   02-22-2018, 09:41 PM
Replies: 15
Views: 3,692
Posted By Habes 1206
I did to do valve clearances. Will check for...

I did to do valve clearances.

Will check for that - thanks.
Forum: ZX-12R   02-22-2018, 05:55 PM
Replies: 15
Views: 3,692
Posted By Habes 1206
Timing Issue

Hi all,

After some advice please!

I have a drag only 05 12 which I blew up 4.5 years ago. Finally got enough $$$ together to get a complete engine from the wreckers which is an 03.

Replaced...
Showing results 1 to 5 of 5

 
 
For the best viewing experience please update your browser to Google Chrome