Kawasaki World banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 1994 zx9r , I bought the bike from a man who was the only owner for the bike and it only has about 12k miles on it . The bike starts up and runs if I spray starting fluid straight to the carbs . But the only problem I have from the bike is that the fuel pump doesn’t prime... when I turn the key over it doesn’t make that vibrating sound from the fuel pump as it should . Can anyone help! I looked all over the internet and still nothing ... this is my last hope before I take it to a shop . The reason I never took it to a shop because I don’t trust them .. SOMEONE HELP! Thanks
 

·
Registered
Joined
·
1,474 Posts
Sorry, Forget this, I was typing from memory.

True bit. The B1/2 fuel pumps were wired differently to the B3/4 and will only prime when the start button is pressed and starter motor relay power is supplied. Rest a finger on the pump and feel for it working.

Wrong bit, but would work on the B3/4 and later zx-9rs."If all the starter interlocks are working then you could put the bike in gear with the side stand down and press the starter button, the starter motor should not turn over because of how the interlocks work but the fuel pump should prime. Have the back wheel on a paddock stand just in case the interlocks are not working as you don’t want the bike leaping forward."
 

·
Registered
Joined
·
1 Posts
Hi all
I have the same problem with a zx9r . Tried everything . Changed the rely , checked the pump on the bench ( fine ) have down the in gear and stand down and the pump primed . What next . Any help would be greatly appreciated
 

·
Registered
Joined
·
1,474 Posts
and the pump primed. What next.
Not the same problem. If yours will not run while the engine is running then you need to chase the Black wire from The ECU and the coil for number 1&4 to the fuel pump power relay.
 
1 - 6 of 6 Posts
Top