Kawasaki World banner

21 - 25 of 25 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #21
You must be feeling loads happier now. (y) and even more when you start riding it. :)
man you have no idea what I’ve been through with this bike.. It was sold to under false info last march, once I got the bike started after I purchased it no more than 8-10 secs of running the piston shot out the bottom of the motor. So every since last March I had a bike I couldn’t do anything with but look, found a motor months later for 1600. Month or so after that got the motor put in, come to find out it was an 04 motor my bike is an 02 so now the shop said I need An 04 ECU. Found one for $100 had to wait a month for the shop to put it on. Now the shop couldn’t figure out why the bike wasn’t starting so it sat in the shop for another month no results.. so I Haida I’ll just bring it home and figure out what to do next. Started doing research myself and read a few forums here and watched a couple YouTube videos and Bam as of yesterday I got the bike to run finally after almost a year of not hearing it nor never riding it..
 

·
Registered
Joined
·
14 Posts
Discussion Starter #22
You must be feeling loads happier now. (y) and even more when you start riding it. :)
now just gotta figure out why it idles down to off after it run for a little while. It looks like a power issue because the dash flickers as the bike idles.. Brand new battery! So maybe the stator or rectifier
 

·
Registered
Joined
·
1,507 Posts
I have a B4, and I found one of the yellow regulator plug wires from the stator was turning to brown because of a poor crimp connection, I cleaned it up and soldered it.
I also noticed the white headlight wire from the fuse in the battery tray was browning out for the same reason, so did the same again. Things like this can put an extra load on the electrical system. You may also want to check the headlight bulb plugs as there prone to this also.
Do you have the idle set to 1k or 1.1k rpm as they don't like being below this?
 

·
Registered
Joined
·
14 Posts
Discussion Starter #24
I have a B4, and I found one of the yellow regulator plug wires from the stator was turning to brown because of a poor crimp connection, I cleaned it up and soldered it.
I also noticed the white headlight wire from the fuse in the battery tray was browning out for the same reason, so did the same again. Things like this can put an extra load on the electrical system. You may also want to check the headlight bulb plugs as there prone to this also.
Do you have the idle set to 1k or 1.1k rpm as they don't like being below this?
All of this is foreign to me brother.. I’m learning as I go what’s what.. This is my first Kawasaki anything so it’s all new to me. Don’t know what the idle set at.. and I think I probably need to strip it naked from fairings to see everything I only had on side of the fairings off. Some of the fairing bolts are stripping when I try to unscrew them. So trying to figure out the best way to get those screws out without stripping them all the way..
 
21 - 25 of 25 Posts
Top