Kawasaki World banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I recently was riding going around 60 when my bike cut off. I coasted to the side of the road and then tried to turn it on. No lights guages nothing electronic turned . Got it back home and found out that the battery wasn't connected tight enough to the positive side and it was shorting out on the metal frame. Fixed some blown fuses . But now the fuel pump doesn't prime or anything when I turn The key on is there anything I could look for to fix this ? Like a relay, fuse, or something.
 

·
Registered
Joined
·
1,437 Posts
But now the fuel pump doesn't prime or anything when I turn The key on?
I take you mean no dash lights like, Oil or Neutral, indicators or horn or city light.
Then you need to check the main fuse, this is located in the battery tray and is hiding under the starter solenoid plug cover. It's a green 30 Amp one.
You may as well check the headlight fuse thats in the battery tray to, it's also a green 30 Amp fuse in its own little fuse holder.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
I fixed all those issues but since the bike died the fuel pump hasn't worked I fixed a fuse in the battery box and a fuse in the fuse box but I don't know what is wrong with the fuel pump and I don't know where to look
 

·
Registered
Joined
·
1,437 Posts
Check fuse 10 in the fuse box. Then check voltage coming out of fuse box on Brown/white wire. Then go to the right hand switching unit plug and check the voltage is still there on the Brown/white wire and then on the red wire coming out from the kill switch. Then the Red wire on the fuel pump relay.
 
1 - 5 of 5 Posts
Top