Kawasaki World banner

1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Having searched a few threads I'm pretty sure I know the answer but I'd like second and third opinions.

A few months ago I committed the cardinal sin of running my bike out of fuel. Totally stupid move on my part. And after bike died I managed to start it three or four times to get up a big hill to the gas station, filled it up and drove the mile or so home. The next day as I was riding about 20 miles to work the engine would cut out a number of times under load. FI light would go on for a second, bike would refire since I was moving. This may or may not happen every time. I've ridden 12 to 15 miles with no issues, ridden 30 miles with one or two hiccups, some days it's four or five times. Some suggestions is sediment at the bottom of tank may have fouled up the filter or screen. Others say fuel pump.

What say the group?
 

·
Registered
Joined
·
6,354 Posts
pull it out and clean it
 

·
Registered
Joined
·
1,021 Posts
Hi you have 2 models listed if its the 00 do as KZ said pull it out and give the pickup mesh a clean and also while its apart change the inline filter do a search someone would have done it and check pump for flow. there is also a pressure relief valve on the fuel injector rail which returns to tank if it is full of crap and not sealing you would not get enough fuel pressure. Now if its the 05 mod its a different setup , the relief valve is in the housing in the tank it just unclips and mine has done in the past, the pickup mesh is the same but the filter is not replaceable its inside the plastic housing (some on here have managed to change it and reglue the housing back together) after all that crap good luck Craig
 

Attachments

1 - 4 of 4 Posts
Top