Kawasaki World banner

1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I am the proud owner of 2 kawasaki ninja zx12's (2000)

I am having a issue with my clutches. I just replaced the fibers and springs.
in exact order they came out. I was very careful about this. once all was put back together the bike turned on fine. but as soon as I put it in first it jumped and shut off.

I had this issue last year with my other 12 but I did not touch the clutches. It was something with the rod that droped into the basket. (I chewed it up thinking kickstand switch, and test several other possiblities) got the new thick rod and worked great. Still shifts hard though.

So I tried the new rod in this bike, no luck. I pulled it all apart again. cleaned thouroghly, noticed some spring marks inside the pressure plate. compared those springs with the old ones.... an inch longer... smdh but happy I found the problem.... NOT, put it all back together and still same issue.

so the stack looks right, but when looking in the oil fill hole the plates and pin don't move a 16th of a inch when the lever is pulled in. I have been testing it with the bike off. because I don't want to kill this rod.

I leave the bike off, put it in first, pull in the clutch lever and try to roll it, and it won't roll, wheels lock, put it in neutral and free roll. it is like this no matter how loose or tight my clutch cable is.


someone please help, I am now clueless and on a budget.
 

·
Registered
Joined
·
1,304 Posts
There's plenty of guys out here who know clutches, and one of the first things they're going to ask you is 'What's your stack height?'
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
I am taking the stack with me to work to get the exact measurements today. as of right now I used the same steels. same springs. The springs they sold me was almost an inch longer than the ones I took out. I did notice the new fibers are much thicker on the inner diameter than the ones I pulled out. and I will have full measurements on here by 3pm est.


does anyone know where I can download the service manuel for the 2000 zx12. I had the pdf but it somehow got lost.

and feel free to email me I have pictures of everything or if you have the pdf of the manuel it would be extremely greatly appreciated

[email protected]
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
problem resolved, I did the stupidest thing in human history.

I didn't see those two itty bitty small spring plates in the way back. so I didn't put the half fiber in first..... DUHHH so mad at myself right now.

but the bike is running great, now I can continue killing Busa's and telling the guys my bike is a 250
 
1 - 7 of 7 Posts
Top