Kawasaki World banner

1 - 6 of 6 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I just got a 2005 kx 85 and my first 2 stroke.
Bike has a lot of power lost through 1-3 gears, and picks up from there.
Bike had a lot of oil ran through it, so I ran the bike to burn the oil out but it's still not helping. Any idea of what it could be?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #2
We'll no help so far.
I ran a compression test.
About 115 psi.
Spark plug looks good.
Still having boging problems..
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
So another update.
Still no help from any one.
Drop the carb it looks good nice a clean.
Air filter was dirty as hell.
so geting a new one.
Reeves look good.
gonna change them out while it's out.

Update after I do more work.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
Put new filter.
Carb cleaned.
Clean the reeds.
Have more power.
Still have a bog.
Throttle cable is sounding like its pinched.
Cluch cable is lose now.
So more work to do.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
Another up date.
Clean carb again.
Ran really good with just a lil bog in 1st.
Then it shut off on me an now won't start.

More work to do.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6
so for all who is reading an if you have the same problem.
1st check every thing on the bike to make sure working right.
2end clean the carb.
3rd if the bike is under 120 psi on compression. rebuild it!!!!!
DONT RIDE THE BIKE UNDER 120 PSI,IT WILL CUASE ALOT OF DAMGE AN MONEY.
 
1 - 6 of 6 Posts
Top