Kawasaki World banner

1 - 8 of 8 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
so my 98' zx9 has started shifting akwardly...i put it in gear and it pops in first...go to shift in to second and it shifts but when i go to let off the clutch and give it gas it hesitates for a second and then feels like it shifts hard in gear....this happens for all gears...im usually shifting at about 4k-6k rpms..could it be the tranny??...chain and sprockets??....clutch??....
 

·
Registered
Joined
·
1,943 Posts
...this happens for all gears...im usually shifting at about 4k-6k rpms..could it be the tranny??...chain and sprockets??....clutch??....
Clutch? No
Sprockets? No
Chain? You mean slack? Maybe.
Tranny? You might think the transmission shift pawl and spring over the drum. 'Usually happens in all gears' kind of tells me the drum, pawl, spring all have something to keeping each gear in its roller-stay. So something around the drum is not staying in place is my guess?

Especially it popping out of first or say that issue, when the chain is not moving, the clutch is not lunging you forward when shifting to 1st, nor does it slip at higher rpm's.
 

·
Registered
Joined
·
12 Posts
Just reading through the forum as I'm having some gear issues too - a few false neutrals, but the main problem is selecting 5th while not under power (happened a few times in last 400 miles). So I'm coasting after a blast in 3rd or 4th, take power off and let bike slow for traffic - as I change up into 5th with no power she grinds trying to find the gear.
Is it worth doing the above - or have I more serious fish to fry? Thanks in advance
 

·
Registered
Joined
·
430 Posts
Had the footpeg shifter problem with my9. Could barely shift up or down. Took it apart was corroded so bad. Clean it up put some lube on it ,shifts beautiful now.
 
1 - 8 of 8 Posts
Top