Kawasaki World banner

1 - 11 of 11 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
My 05 zx12r was stalling after pressing the clutch bike would die just as I clicked into forst gear...( kick stand was up) replaced the gear position sensor is still dying after down shifting to 1st to take off, checked every thing with kick stand safety, all is well. Keep in mind I bought the bike as a project for 700$ bucks running, wiring was absolutely wack from previous owner. (I put a new harness on) of a parts bike a buddy had. Anything helps I’m kind of leaning toward the key needing to be resynced to ecu, as the ignition looks new and isn’t the favor the key. Thanks for any help in advance!
 

·
Registered
Joined
·
1,901 Posts
I agree with tomonever, the clutch safety switch may need cleaning/servicing. Had this happen to me on a couple of occasions over the years. At least it would rule it out if not the problem.
 

·
Registered
Joined
·
2,857 Posts
Is the clutch itself adjusted properly? Does it jump when you put it in first gear?
Also, what is the idle rpm set to?

cmg
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
Is the clutch itself adjusted properly? Does it jump when you put it in first gear?
Also, what is the idle rpm set to?

cmg
Idles at 1100, and no doesn’t jump at all as if they clothes aren’t ingaging properly so I assume they are correct,it just dies.
 

·
Registered
Joined
·
2,857 Posts
You said you replaced the wiring harness?
Did you plug in the connectors properly under the ram air cover on the left side? This is the side that the clutch switch is routed.

cmg
 

·
Registered
Joined
·
1,484 Posts
I'm assuming that because yours is 2005 it's a B3+, which means it will have a small Black diode attached to 2 wires hanging loose around the plugs of the fuse box. this diode could be bust, missing, or loose, I'm fairly sure this is the part number for one Rectifier diode 21061-0001 used in a few different Kawasakis between 2003 and 2006.
Also, like what's been said earlier the clutch switch is also a common suspect, as the contacts inside corrode up giving a poor contact to link the 2 wires in your B3+ system.
If you want to see the inside of the clutch switch looks like look at this thread I did on a zx9 which uses the same switch, yours will only have 2 wires because you also have the diode in the system, and the pin locations are slightly different. Clutch switch checking, cleaning and/or replacing. - ZX-9R.Net
 
  • Like
Reactions: zx12r_warren

·
Registered
Joined
·
11 Posts
My 05 zx12r was stalling after pressing the clutch bike would die just as I clicked into forst gear...( kick stand was up) replaced the gear position sensor is still dying after down shifting to 1st to take off, checked every thing with kick stand safety, all is well. Keep in mind I bought the bike as a project for 700$ bucks running, wiring was absolutely wack from previous owner. (I put a new harness on) of a parts bike a buddy had. Anything helps I’m kind of leaning toward the key needing to be resynced to ecu, as the ignition looks new and isn’t the favor the key. Thanks for any help in advance!
I had the same issue with 00’ zx12. What I found that worked is putting it in 1st, and starting it with the clutch in. Mine tried to roll forward while it was starting, but once it was started it returned to normal.
 
1 - 11 of 11 Posts
Top