Kawasaki World banner
1 - 6 of 6 Posts

·
Registered
Joined
·
151 Posts
Discussion Starter · #1 ·
Gents,

So I'm in the process of selling my 01' 12R. Just got it safetied today and it requires new steering head bearings. Still running the original after 20yrs.

What do you guys recommend? Will the "All Balls" tapered bearing kit work or should I stick with OEM(if they even exist anymore)?

Cheers!
 

·
Registered
Joined
·
2,127 Posts
I have used All-Balls bearings twice before, and for some reason they never quite fixed the headstem knock/slack. It would work for a while then get slack again. I went back to oem which works fine for me. Now I'm not saying they are no good, just my experience, maybe I did something wrong with installation, but the oem ones are okay. I'm sure others will have good reports about All-Balls.
 

·
Registered
Kawasaki zx12r 2003
Joined
·
24 Posts
I have used All-Balls bearings twice before, and for some reason they never quite fixed the headstem knock/slack. It would work for a while then get slack again. I went back to oem which works fine for me. Now I'm not saying they are no good, just my experience, maybe I did something wrong with installation, but the oem ones are okay. I'm sure others will have good reports about All-Balls.
Today I got my bike back from a fork seal change. I also had the head bearing changed at the same time. The original bearings were ok but just had a little knock when breaking so I figured why not get them changed. They've been replaced with all balls and tbh, the knock is still there. The shop tightened the headstem further and the knock is still there. Is this a normal thing for the zx12?
 

·
Registered
Joined
·
1,587 Posts
It may not be the head bearings but the pads in the calipers grabbing the disc and then the pads getting lifted into the top of the caliper and causing it to click.
 

·
Registered
Joined
·
2,127 Posts
Ninjayorkie is right, it could be the brake pads.
Still, I had the same problem with All-Balls bearings. Once I changed back to oem bearings the knock went away.
Could have been my installation method, I don't know.
Your results may vary!
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top