Kawasaki World banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi,

I've just purchased a zx7 97 P2 I think. it has 29k with no history.
On first inspection the bike seems and rides fine but today I have noticed something I don't like.

Riding the bike normally with revs under 5k the bike sounds like a zx7, if I give some beans and rev over 5k (Only when warm) I can hear a knocking/thumping noise from the engine. It seems like its coming from the front of the engine. Also and may not be related its happened a few times, it seems to pop/ping one big noise like exhaust backfire but comes from the engine. again this has only happened a couple of times.

I have changed the oil, 10w40 semi, new filter. it was missing the top cam chain guide so fitted a new one. looked like it had been hitting the top studs.


Anyway, Any information you can give me would be great. Anything I can check myself to keep the repair bill down too.

thanks in advance.
Paddy
 

·
Registered
Joined
·
238 Posts
You are not going to get the correct answer on here because there are so many possible things that can go wrong on an 18 year old bike and most of it is going to be guesses and speculation.
So my suggestion is you take it to someone who knows Kawasakis in your area like Tim Blakemore in Bristol to get an accurate answer.
 

·
Registered
Joined
·
16 Posts
I had a p2 with same milage with a knocking sound..I swear it was metal on metal, but under inspection I was told to check my headers and sure enough they were lose..tightened them up and knock went away..fingures crossed for you
 
1 - 4 of 4 Posts
Top