Kawasaki World banner

1 - 9 of 9 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I have a 94 ZX9r B1. 9094 miles. Sitting still it runs great, idols great, revs up great. When I ride it down the road, it acts like it runs out of fuel. Then it dies. After several attempts of starting it, with choke on and off, it finally starts. Runs great, until I take off then acts like it runs out of fuel again. I can see that the fuel filter is full of fuel. It has a new fuel pump. Carbs recently synced. Any ideas???
 

·
Registered
Joined
·
577 Posts
You're sure the fuel pump works? Because it sounds like it doesn't despite being replaced.

I would pull the fuel line after the pump and point it at a bucket during KOEO (key on, engine off). The pump should deliver plenty of fuel continuously.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Ok.. So, with the line removed and the key on, the fuel pump does not run. If I'm not mistaken, doesn't the fuel pump only run when the bike is starting and running? Also, the right side coil isn't mounted because the bolts pulled out. Does it need to be mounted to run properly?
 

·
Registered
Joined
·
1,430 Posts
Fuel pump primes while the start button is pressed bypassing most of the internal workings of the fuel pump power relay. While the engine is running the fuel pump power relay works from the pulses firing the coil to 1 and 4.
Find the relay and make sure all the plug pins are clean, it's common for them to corrode a little over time.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
Ok.. I'll check the connections. When sitting still, this bike runs great. Great throttle response. Take off down the road and get about 3000 rpms and it starts cutting out, then dies. You can choke it and start it back up but then keeps dying. Can't touch the throttle at all. I can lift the tank and see that the filter is full of fuel. After a few minutes, the bike will start. I put the tank back down and take off. Then the cycle repeats. Has me really confused.
 

·
Registered
Joined
·
1,430 Posts
Try pressing the start button while riding and if the revs pick up, then its fuel pump relay or wires to it.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #8
Ok, so I changed out the fuel pump again and that solved half my problem. It runs good and idols good. When I take off in first gear it runs great. I can run it up to 5000 rpm and it doesn't hesitate at all. When I shift to second and it gets to 3000 rpm, it bogs down. I can open the throttle up all the way and it jerks and jumps the gradually takes off. I just put a new set of plugs in and it does the same thing. Any ideas??
 

·
Registered
Joined
·
577 Posts
Still sounds like fuel starvation. You have enough in the bowls till you hit second then the jets run dry.

I recommend a fuel delivery test described by the service manual.
 
1 - 9 of 9 Posts
Top