Kawasaki World banner

1 - 9 of 9 Posts

·
Registered
Joined
·
2,396 Posts
Discussion Starter #1
Anyone ever had this problem before...went out on the bike today for a short ride.. 10 miles max parked her up and when I came back I noticed my LCD display looked like it had water in it or some other sort of liquid actually under the clear plastic cover....? see picture below....



Got home an hour or so later and noticed it was virtually gone ?.....baffled as bike hasn't got wet in last 3 years or more any idea what this stuff was ?.
 

·
Registered
Joined
·
1,462 Posts
Take the clocks off, open them up and use the wife's hairdryer to get rid of the moisture.
 

·
Registered
Joined
·
2,396 Posts
Discussion Starter #5
Virtually all gone now...how weird... I think you guys were spot on with the condensation theory....still baffled why it would occur ?
 

·
Registered
Joined
·
2,396 Posts
Discussion Starter #7
May be it is due to all the washing of the bike you do. Or is DOA exagerating about that.:rotflmao:
My bike has not been washed in 5 years....she gets a polish wash and that's it :thumbup: she is all SORN now till spring.....:zxblack:
 

·
Registered
Joined
·
1,462 Posts
That moisture will now be sat on the circuit board, so I'd still open it up and dry it off.
 

·
Registered
Joined
·
1,156 Posts
May be it is due to all the washing of the bike you do. Or is DOA exagerating about that.:rotflmao:
:crackup::rotflmao: yep

its properly crying as the fact you took her out for a ride.:rotflmao:

making her feel like a bike again and not a garage ornament :thumbup:
 
1 - 9 of 9 Posts
Top