Kawasaki World banner

1 - 10 of 10 Posts

·
Site Admin
Joined
·
486 Posts
Discussion Starter #1
By popular demand, here is a forum for the Kawasaki two stroke engine motorcycles.

If you have a Kawasaki 2-stroke bike, post up a new thread and tell us about it and let's see some pictures!

:thumbup:
 

·
Registered
Joined
·
1 Posts
hi all.. i'm new here, been quite active in kawasakikps.com forum, but for now would like to make a change for something fresh & new... cheers :thumbup:
 

·
Registered
Joined
·
4 Posts
Hi and hello to everyone from Singapore.. hope to find good friends from Thailand,KL and Indonesia.. I am a owner of a 2003 Kawasaki KR Superkips.. hope can learn new things from here..
 

·
Registered
Joined
·
1 Posts
By popular demand, here is a forum for the Kawasaki two stroke engine motorcycles.

If you have a Kawasaki 2-stroke bike, post up a new thread and tell us about it and let's see some pictures!

:thumbup:
where can i find piston ring for my kawasaki ssr leostar 2 stokr...tia:banghead:
 

·
Registered
Joined
·
1 Posts
78 kx250

I don't see anywhere on this page how to post a new thread. I'm looking for a left handgrip for my 78 KX250. Part# 46075-1001 or 46075-031. Any help would be appreciated. Mark
 

·
Registered
Joined
·
1,489 Posts
Click on the green words "Two Strokes" just below this post....
Kawasaki Forum :: KawasakiWorld.com > Kawasaki Motorcycles > Two Strokes
It will take you to the 2 stroke home page. Start a new topic there. :thumbup:
 

·
Registered
Joined
·
2 Posts
Looking for help with old wiring

I've got a '75 KT250 that my son has dumped on me to install an ignition switch and straighten out the carb. I've stripped down the harness and repaired all of the wiring (new connectors, new wire in some areas, etc.) and it fully complies with the diagram (attached) from the magneto out. The problem is that it starts only when the Bk/W wire (ignition from the CDI to the switch) is not grounded. I can't figure out how to have it not ground when all the other wires to/from the ignition switch are grounded. All theories, ideas and any witchcraft gratefully accepted. Thanks.
 

Attachments

·
Registered
Joined
·
2 Posts
kips

is there some magic system to putting the rods back in the exhaust rod ports on a 93kx500 that every manual ive read fails to mention. i am tired of draining antifreeze and removing the barrel just to see again i did it like the book shows. im lacking low and mid range performance after the rebuild and decarbonation of the exhaust kips system. wtf am i needing to do to get my low speed and mid speed performance back.... with my luck all it is is the plug is fouled. starts on first kick nearly every time. even on a cold start.any input would be great.
 
1 - 10 of 10 Posts
Top