Kawasaki World banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
2002 zx12r
Customer stated it was hard starting warm and we noticed the battery cranked super slow tested it. Wouldn’t charge up. Replaced battery, cranks great. Won’t start though. Sprayed with starting fluid, fires up and runs on its own fuel. Tested fuel pump, tested out below recommend flow and pressure. Installed fuel pump rebuild kit, reads great now. Still doesn’t start without spraying intake with starting fluid. Once sprayed it fires up still and stays running on its own fuel and pump and all. Got it up to running temp and shut it off. Still won’t start back up without fluid. Any ideas?
 

·
Registered
Joined
·
1 Posts
2002 zx12r
Customer stated it was hard starting warm and we noticed the battery cranked super slow tested it. Wouldn’t charge up. Replaced battery, cranks great. Won’t start though. Sprayed with starting fluid, fires up and runs on its own fuel. Tested fuel pump, tested out below recommend flow and pressure. Installed fuel pump rebuild kit, reads great now. Still doesn’t start without spraying intake with starting fluid. Once sprayed it fires up still and stays running on its own fuel and pump and all. Got it up to running temp and shut it off. Still won’t start back up without fluid. Any ideas?
I would recommend trying a hotter plug if there is a possible hotter plug! I have a 99 Vulcan with less than 5000 miles, and My problem is that it will not idle. It never fails to start but it just will not stay running! any ideas, anyone?
 

·
Registered
Joined
·
3,105 Posts
Clamp off the fuel line that returns fuel to the tank. This will create high psi in the fuel rail.
See if it will start. If it does then you will know the regulator is malfunctioning. This exercise might get the reg guts freed up. May work properly after. If not , replace the regulator. Check regulator vacuum line too.

cmg
 
1 - 4 of 4 Posts
Top