Kawasaki World banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi, I'm a slight fraud as I have a zx12 engine kit car but was hoping someone could help me please. Its decided not to start when hot. Starts on the button when cold but when hot Turns over nicely but won't fire into life and fl light flashes when turning over. No current or stored codes. It always been on the button hot and cold but friday it sat in the hot sun all day and then wouldn't start until it cooled later that evening. Since Then fine when cool until you get it warm then won't start. as it cools she fires straight up again. Any suggestions? Thanks
 

·
Registered
Joined
·
3,105 Posts
1. Fuel tank vents
2. Fuel pump/filters
3. Fuel pressure regulator
4. IAT sensor in airbox
5. Coil boots dried out grounding spark

When hot, if you spray some fuel or starting fluid in the throttled bodies does it start and stay running?

just some thoughts to start with

cmg
 

·
Registered
Joined
·
1,580 Posts
If the engine turns over but will not start and everything else seem ok then it could be a faulty Cam Position sensor, sometimes even if the resistance check is ok.
But before buying one as there not that cheap, do a resistance check through the kill switch as any resistance here can kill the voltage over the stick coils.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
Slight update, it started but didn't want to tick over to start with which it normally does and went down the road feeling OK. 1 mile down the road and it just cuts out. Then it would fire if I started it as soon as I turned it on but just died within a second or 2. Only hear the pump occasionally. Got it home, replaced checked fuel filter which was spotless, the pump then did kick in most times ignition went on but only for around a second even with the fuel pipe going into a container which was about an egg cup full. I feel this should have been more and longer??
Well put it back together and she fires and sits there ticking over nicely.🤷
Definitely seems like something doesn't like getting warm but now it's died on the road I don't fancy to many test drives
 

·
Registered
Joined
·
1,580 Posts
I would also be checking the battery condition a weak battery will cause the same conditions, I know yours is in a car but still worth load checking it while trying to start the engine.
 
  • Like
Reactions: Craig mk indy
1 - 5 of 5 Posts
Top