HELP! 2006 Z750 problem! - Kawasaki Forum :: KawasakiWorld.com
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 09-11-2019, 03:03 PM Thread Starter
Junior Member
 
Join Date: Sep 2019
Posts: 1
HELP! 2006 Z750 problem!

Hello guys i'm Costa Rica, i have a problem with my Z750, sometimes when the bike is cold and i turn it on it goes normally but after travelling like a mile it dies if i don't accelerate it, if i use the choke the bike can iddle but at very low rpm, if i don't use the choke the bike dies, the weird stuff about this is that if i rev the bike to it's redline the problem fixes and the bike idles normally, a couple days ago i travelled a long trip, the bike was at normal temperature 80 celsius, but it started raining a lot so the temperature dropped to 55-60 celsius and the problem happened again, if i don't accelerate the bike dies, obviuslly i didn't choke the bike because i was driving, then i redlined again and it fixed, i don't know the cause of the problem so i hope you guys can help me.

Recently i went to the mechanic and cleaned the injectors and fuel pump, he told me that the spark plugs had good color on it, those are iridium ones actually.
The air filter is kinda old but i really don't know if that can be the problem, i live in Costa Rica so if i order an air filter it may take like 3 weeks.
The bike has an Akrapovic exhaust and it stutters from 2.5-3.5k RPM, i really don't know if the lack of backpressure is the reason of it, after that RPMs the bike has normal power, i guy from this forum said that this bike (Z750) stutters with aftermarket exhausts.

So a summary is that sometimes the bike dies if i don't accelerate it, only when the bike is cold or the rains cools the engine, but if i accelerate it hard to redline the problem solves, what do you think? I will really appreciate your help!
venomz750 is offline  
Sponsored Links
Advertisement
 
Reply

  Kawasaki Forum :: KawasakiWorld.com > Kawasaki Motorcycles > Z750 Z1000

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Forum :: KawasakiWorld.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome