FI Light on and sounds bad - Kawasaki Forum :: KawasakiWorld.com
 
LinkBack Thread Tools Display Modes
post #1 of 12 Old 10-16-2007, 07:16 AM Thread Starter
Junior Member
 
Join Date: Apr 2005
Location: SOUTH CAROLINA
Posts: 4
FI Light on and sounds bad

Need help ! can anyone tell me how to read the computer to find out what is wrong
bad zx12 is offline  
Sponsored Links
Advertisement
 
post #2 of 12 Old 10-16-2007, 08:33 AM
At Banned Camp
 
Join Date: May 2003
Location: VA
Posts: 5,436
Sounds like mine yesterday....spark plug 4 wasn't in all the way :oops: Have you messed with the plugs recently?

A.
shiphteey is offline  
post #3 of 12 Old 10-16-2007, 10:40 AM
Senior Member
 
shiggsy's Avatar
 
Join Date: Feb 2004
Location: Kent, England
Posts: 1,275
Remove the rear seat and lift out the storage box. There will be a yellow wire with a female bullet connector (on the right side as you stand behind the bike). I have made up a wire with 2 male bullet connectors on either end, plug one end into the yellow wire, turn on the ignition and within 2 seconds ground the other end of the wire to the frame (non painted part) and hold it there. The FI light will then flash codes at you.

Two long flashes + three short flashes gives fault code 23.
Three long flashes + four short flashes gives fault code 34
etc etc.
Once it's given you all the fault codes it will recycle from the begining again.

To get to stored codes and not just present fault codes repeat the above but instead of grounding the wire once and holding, ground it 5 times quickly and then hold it.

Below are the fault codes:





hung like Einstein, smart as a horse
shiggsy is offline  
Sponsored Links
Advertisement
 
post #4 of 12 Old 10-16-2007, 11:55 AM
Member
 
Join Date: Sep 2006
Location: Newcastle Australia
Posts: 82
How handy is that!!

Winners are prepared to do what losers won't!
06 ZX12R, Full Arata, PCIII mapped, K&N
..looking for a 07 R1 track bike....sad, but true..
aussiezx12r is offline  
post #5 of 12 Old 10-17-2007, 08:47 AM
Senior Member
 
abnzx12pilot's Avatar
 
Join Date: Sep 2002
Location: Des Moines, Iowa
Posts: 265
Send a message via Yahoo to abnzx12pilot
you know how long I searched the forums and talked with people for this information?! I finally figured it out. Pisses me off. best of luck bad zx12. I had a faulty air pressur sensor

This one bagat this one and that one begat that one and begat, begat, begat, and lo and behold someone said some shit and..... Just how retarded are you. I reckon I aint got no reason to kill nobody. hmm mmm.
abnzx12pilot is offline  
post #6 of 12 Old 07-31-2010, 03:07 PM
Junior Member
 
Join Date: Jul 2010
Location: mississippi
Posts: 11
shiggsy i am new to the kawasaki world i came from suzuki (must say will NEVER EVER go back) i have a 2000 zx12r and my FI light has come on. i took advantage of your post with the ecu codes and it pointed me to the #4 injector (code 44). I changed the spark plugs and made sure the injector wire was not damaged can you or anyone else give me some insight on what to do next.
2000zx12r is offline  
post #7 of 12 Old 03-08-2013, 12:34 AM
Member
 
Gosling1's Avatar
 
Join Date: Jun 2005
Location: Anarchy Road, Outback Oz
Posts: 50
Bit of a thread revival - but I am stumped with an error code at the moment.......

32.

Three long flashes then 2 short ??

Not listed in the error codes above. The bike is a 2005 ZX12R, fitted with a PC3, secondary flies removed (both TPS fitted and working OK though).

Does anyone have any idea what the error code 32 could mean ?

cheers
Gos

"So long as the paperworks clean, you boys can do what you like out there........."
Gosling1 is offline  
post #8 of 12 Old 03-08-2013, 12:48 AM
drp
Senior Member
 
Join Date: Jul 2005
Location: No where
Posts: 1,897
Garage
.


32 - sub throttle sensor malfunction, wiring open or short.



ZX-12R B model manual here ZX-12R B Manual


Thanx Dave.

.
drp is offline  
post #9 of 12 Old 03-08-2013, 12:59 AM
Member
 
Gosling1's Avatar
 
Join Date: Jun 2005
Location: Anarchy Road, Outback Oz
Posts: 50
cheers buddy appreciate the help

"So long as the paperworks clean, you boys can do what you like out there........."
Gosling1 is offline  
post #10 of 12 Old 03-17-2013, 03:48 AM
Junior Member
 
AMMOV's Avatar
 
Join Date: Jan 2013
Location: Orange Park
Posts: 10
I had and F1 light on. . Put in shop and it was a bad atmospheric sensor.. Cost me about 170 to get repaired.. Now she rides like a champ...
AMMOV is offline  
post #11 of 12 Old 06-26-2013, 12:02 PM
Junior Member
 
Join Date: Jun 2013
Location: florida
Posts: 1
fi help

I have a 2000 zx12r and fi light came on and started running like crap I check codes and it gave me 51 #1 coil so I replaced all 4 and new plugs and light is still on and now getting two codes 51 coil again and 23 cam sensor im pulling my hair out can anyone help
ripper is offline  
post #12 of 12 Old 07-21-2016, 07:15 AM
Member
 
Join Date: May 2016
Location: Uk
Posts: 65
Quick bump my zx12r low end lumpy rev jerky on set off .
Touched yellow wite to earth and it just constantly flashers ie second a part ? Dose this mean theres no faults
Powernut is offline  
Reply

  Kawasaki Forum :: KawasakiWorld.com > Kawasaki Motorcycles > ZX-12R

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Forum :: KawasakiWorld.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sounds good n52 ZX-10R 1 11-01-2010 07:55 AM
Sounds fmiliar.... Lucky13uk ZX-12R 25 10-02-2010 03:17 PM
Sounds like BS to me! But I don't have a clue. Chango ZX-12R 45 06-18-2009 05:15 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome