Funky Charging System - Kawasaki Forum :: KawasakiWorld.com
 1Likes
  • 1 Post By CoreyClutch
 
LinkBack Thread Tools Display Modes
post #1 of 10 Old 04-11-2019, 01:54 PM Thread Starter
Junior Member
 
CoreyClutch's Avatar
 
Join Date: Sep 2018
Posts: 25
Funky Charging System

Hey guys, long story short my charging system is acting wonky yet again and putting out 17.5v at idle, and 20v when riding. I’ve replaced the rectifier twice, the stator once and rewired all the wires joining the two as well as the oil wicking mod. I just ordered a mosfet rectifier to see if that will fix anything since I’ve heard the oem rectifiers for the 12’s are hit or miss. Anyone have any other suggestions...? I don’t know what else to do.
CoreyClutch is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 04-11-2019, 03:34 PM
Senior Member
 
KZScott's Avatar
 
Join Date: Jan 2007
Location: Ontario, Canada
Posts: 6,246
Send a message via MSN to KZScott
hows the ground wires? maybe it cant get rid of its extra

01 ZX-12R 8.84 @ 156.3 on dot tires, NA.... turbo 8.47 @ 164
00 ZX-12R 8.62 @ 165.2 no bars, slicks, 55 shot... turbo 8.32 @ 173
00 ZX-12R 1: 222.046 1.5: 226.390 Worlds Fastest NA Kawasaki
00 ZX-12R street turbo 1: 227.9 1.5: 234.1
00 ZX-12R LSR turbo 1: 263.1 1.5: 266.5 Worlds fastest ZX-12R CMG Racing RCC Turbos
KZScott is offline  
post #3 of 10 Old 04-11-2019, 04:29 PM Thread Starter
Junior Member
 
CoreyClutch's Avatar
 
Join Date: Sep 2018
Posts: 25
Ground is good. Had it professionally wired. The guy did a really good job.
CoreyClutch is offline  
Sponsored Links
Advertisement
 
post #4 of 10 Old 04-12-2019, 12:14 AM
Senior Member
 
ninjayorkie's Avatar
 
Join Date: Dec 2004
Location: Altofts zx-12r B4 UK
Posts: 1,409
Garage
Could it be a faulty meter?

For Tech Questions Bike Model letters and Country are more useful than saying the year, for UK owners anyway, as registration year is not always the year of manufacturer model.
ninjayorkie is offline  
post #5 of 10 Old 04-12-2019, 09:09 AM Thread Starter
Junior Member
 
CoreyClutch's Avatar
 
Join Date: Sep 2018
Posts: 25
Quote:
Originally Posted by ninjayorkie View Post
Could it be a faulty meter?
I don’t think so, as it was showing the right voltage at about 13.5 when it was first installed.

Also forgot to mention that it blew my headlights yet again
CoreyClutch is offline  
post #6 of 10 Old 04-12-2019, 08:44 PM
Member
 
Nitemare12's Avatar
 
Join Date: Apr 2014
Location: Hampton,va
Posts: 50
I had the same problems several times ...go with Rick's Electronics directly ( not from eBay, not from Amazon )..directly Rick's Electronics go with his mosfet rectifier and stator at the same time ...no more problems I'll put money on that one again.
Nitemare12 is offline  
post #7 of 10 Old 04-13-2019, 12:54 AM
Senior Member
 
ninjayorkie's Avatar
 
Join Date: Dec 2004
Location: Altofts zx-12r B4 UK
Posts: 1,409
Garage
Quote:
Originally Posted by CoreyClutch View Post
Also forgot to mention that it blew my headlights yet again
I'd check the headlight bulb plugs for poor connections.

For Tech Questions Bike Model letters and Country are more useful than saying the year, for UK owners anyway, as registration year is not always the year of manufacturer model.
ninjayorkie is offline  
post #8 of 10 Old 04-13-2019, 10:39 AM Thread Starter
Junior Member
 
CoreyClutch's Avatar
 
Join Date: Sep 2018
Posts: 25
Quote:
Originally Posted by Nitemare12 View Post
I had the same problems several times ...go with Rick's Electronics directly ( not from eBay, not from Amazon )..directly Rick's Electronics go with his mosfet rectifier and stator at the same time ...no more problems I'll put money on that one again.
Just ordered a shindengen mosfet from a reliable seller. Really hoping that it does the trick.
CoreyClutch is offline  
post #9 of 10 Old 04-28-2019, 01:20 PM Thread Starter
Junior Member
 
CoreyClutch's Avatar
 
Join Date: Sep 2018
Posts: 25
So update on this...

I am now running a Shindengen mosfet fh020aa R/R and so far after about 50km it’s holding steady at 13.5v.

I’ll keep this post updated if anything comes up in the future. Here’s hoping nothing does however lol.
CoreyClutch is offline  
post #10 of 10 Old 05-19-2019, 06:38 PM Thread Starter
Junior Member
 
CoreyClutch's Avatar
 
Join Date: Sep 2018
Posts: 25
Another update to the mosfet rectifier. After about 600km’s it’s still holding as strong as when I had it put in. Just figured I’d keep this post updated in case.
ciderking likes this.
CoreyClutch is offline  
Reply

  Kawasaki Forum :: KawasakiWorld.com > Kawasaki Motorcycles > ZX-12R

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Forum :: KawasakiWorld.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
ZX-12 Full Muzzy Stainless/Carbon Fiber System For Sale krivs388 Classifieds 10 02-09-2018 04:03 PM
Charging issues. Please help to diagnose. Stingray69 ZX-12R 2 12-12-2017 05:06 PM
Can charge system withstand Savagerider ZX-12R 1 09-12-2017 09:50 PM
Is this a good way to know if charging system is OK? Canadianzx12r ZX-12R 2 05-12-2017 06:07 AM
FS akrapovic full system lyhneDk ZX-12R 3 10-25-2016 01:19 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome