Soft clutch when engine is hot - Kawasaki Forum :: KawasakiWorld.com
 
LinkBack Thread Tools Display Modes
post #1 of 9 Old 09-18-2019, 11:18 PM Thread Starter
Junior Member
 
Join Date: Sep 2019
Posts: 6
Soft clutch when engine is hot

Hi fellas new to the site. I have 2000 zx12. Runs great but when it gets hot the clutch gets soft and doesnt disengage. This happens till i get through traffic run the bime till it cools off then it goes back to normal. When i say gets soft the lever is no longer solid. Gets hella slack in it like the cable is streched. Anyone have a solution?
Ivan Webb is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 09-19-2019, 09:37 AM
Senior Member
 
Join Date: Apr 2019
Posts: 131
Yea, new clutch time
Jpowell490 is offline  
post #3 of 9 Old 09-19-2019, 12:46 PM
Senior Member
 
Join Date: Nov 2010
Location: detroit michigan
Posts: 2,536
Quote:
Originally Posted by Ivan Webb View Post
Hi fellas new to the site. I have 2000 zx12. Runs great but when it gets hot the clutch gets soft and doesnt disengage. This happens till i get through traffic run the bime till it cools off then it goes back to normal. When i say gets soft the lever is no longer solid. Gets hella slack in it like the cable is streched. Anyone have a solution?
The A1 (2000) puller rod may be flexing. It’s the part that is sticking out of the clutch cover. The cable hooks on it. The 2003-2005 puller rod is upgraded from the A1 model.

Also, in the manual it demonstrates the angle the arm should be at if your clutch pack stack height is correct. Look at that before you spend money.

cmg
color me gone is offline  
Sponsored Links
Advertisement
 
post #4 of 9 Old 09-20-2019, 06:32 AM
Senior Member
 
Join Date: May 2016
Location: Yes
Posts: 597
FU

.






.

.Learn to ride on a hayabusa! Then graduate to the 12.
olajoe808 is offline  
post #5 of 9 Old 09-22-2019, 02:23 AM Thread Starter
Junior Member
 
Join Date: Sep 2019
Posts: 6
Its a brand new clutch pack and shutter spring. New clutch springs. Will the new puller rod fit the 00a1?
Ivan Webb is offline  
post #6 of 9 Old 09-22-2019, 04:31 AM
Senior Member
 
Join Date: Nov 2010
Location: detroit michigan
Posts: 2,536
Quote:
Originally Posted by Ivan Webb View Post
Its a brand new clutch pack and shutter spring. New clutch springs. Will the new puller rod fit the 00a1?
Yes

Is this where your puller rod is oriented? Take up the slack in the puller rod coil spring with pressure from your finger.

cmg
Attached Images
File Type: png 899F6EF1-D9E9-481F-B7BF-3458C7ABA2ED_1569152067350.png (2.56 MB, 14 views)

Last edited by color me gone; 09-22-2019 at 04:36 AM.
color me gone is offline  
post #7 of 9 Old 09-22-2019, 08:54 AM Thread Starter
Junior Member
 
Join Date: Sep 2019
Posts: 6
Yes.
Ivan Webb is offline  
post #8 of 9 Old 09-22-2019, 10:06 AM
Senior Member
 
Join Date: Nov 2010
Location: detroit michigan
Posts: 2,536
Well, in the past, we have experienced the puller rod twisting torsionally when we pulled the clutch. Albeit we had heavy clutch springs.
The a1 model is very thin in the middle. The one that replaced it in later models is beefier.

Have you pulled the clutch cover to see if the frictions are dry? There is a oil mod that Kzscott posted. It’s a little involved but doable.

cmg
color me gone is offline  
post #9 of 9 Old 09-30-2019, 10:18 PM Thread Starter
Junior Member
 
Join Date: Sep 2019
Posts: 6
Plates arent dry. Waiting on a new rod see if that cures the problem. Whats this oil mod?
Ivan Webb is offline  
Reply

  Kawasaki Forum :: KawasakiWorld.com > Kawasaki Motorcycles > ZX-12R

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Forum :: KawasakiWorld.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome