Intermittent Fi light troubles... advise? - Kawasaki Forum :: KawasakiWorld.com
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 08-02-2003, 07:30 PM Thread Starter
 
Join Date: Sep 2002
Posts: 645
Intermittent Fi light troubles... advise?

My 01 seems to have developed a small issue. A few times while on the highway, semi-sane speeds:), my Fi light comes on for no reason. Usually goes out within a few minutes, for no reason. The bike seems to work great when it is on. Is it a glitch or may there be a problem?

Thanks all.
Green12RPilot is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 08-02-2003, 07:52 PM
 
Join Date: Jul 2002
Posts: 207
It has hapened to me and a few others and the common problem seems to be loose electrical connections. At the very least, it is a simple way to start out before diving into more complicated solutions.
nativefl is offline  
post #3 of 6 Old 08-03-2003, 01:31 PM
 
Join Date: Aug 2002
Posts: 410
I know I'm beginning to sound like a broken record on this subject but here goes: Dude, read the codes!!!! If a loose connection is the problem, it will most likely tell you which component has the loose connection. Regardless, it's better than flying blind when you're troubleshooting it.
12RPilot is offline  
Sponsored Links
Advertisement
 
post #4 of 6 Old 08-03-2003, 03:24 PM
Senior Member
 
K Williams's Avatar
 
Join Date: Aug 2003
Location: NY, USA
Posts: 485
Mine would do the same thing at speeds 30mph and below. Punch it, and the FI light would disappear. During normal commuting, I'd just turn the bike off hten back on. The light would be gone. The ZX-12R has a lot of weird quirks(Like that oil seepage problem...which they finally issued a recall for. Unfortunately my bike was already unridable from an accident when the recall notice arrived.), but I still love the bike.

K. Williams
'01 ZX-12R
K Williams is offline  
post #5 of 6 Old 08-03-2003, 07:30 PM
 
Join Date: Jul 2002
Posts: 207
K,

That was exactly the problem I was having. Took it into the dealer and they rechecked and re-lubed the connections and I haven't had a problem since. That was 10000 miles ago.
nativefl is offline  
post #6 of 6 Old 08-04-2003, 09:32 AM Thread Starter
 
Join Date: Sep 2002
Posts: 645
OK... thanks guys! I will zip on up to my mechanic and have him fix up the connections.
Green12RPilot is offline  
Reply

  Kawasaki Forum :: KawasakiWorld.com > Kawasaki Motorcycles > ZX-12R

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Forum :: KawasakiWorld.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Intermittent headlight failure Paddo ZX-12R 2 11-19-2011 07:15 AM
Intermittent Engine Noises. faction200707 ZX-12R 4 11-08-2009 06:11 PM
Intermittent Rough Running shiggsy ZX-12R 19 08-10-2007 01:49 AM
HELP!!! Intermittent electrical problem gymply ZX-12R 7 10-11-2005 01:15 PM
Fuel Injection Light - Intermittent fault 2000 zx12r a1 deggs ZX-12R 6 10-02-2003 07:37 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome